question

T. Kincaid avatar image
T. Kincaid asked

Minumum SDK for 2nd Generation Kindles

I'm developing with a minimum SDK of 14 (4.0). According to this document, that is lower than 2nd generation Kindles. https://developer.amazon.com/appsandservices/solutions/devices/kindle-fire/specifications/01-device-and-feature-specifications However, I received this notice. "does not install on Kindle Fire. This app requires a higher Android SDK version than what is currently used to develop for Kindle Fire. Kindle Fire uses Android 2.3.4 - API Level 10. Devices: Fire HD 8.9 WAN (2nd Gen). Fire HD 8.9 Wifi (2nd Gen). Kindle Fire HD 7 (2nd Gen). Kindle Fire (2nd Gen)." I did not check the first generation Kindle when submitting, but all other Kindles. What is the minimum SDK version needed to run on 2nd generation Kindles?
fire tablet
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

T. Kincaid avatar image
T. Kincaid answered
The exact same binary except for changing the version code was accepted for 3rd and 4th generation Kindles. Shouldn't sdk 14 run on 2nd generation?
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Nick Gardner avatar image
Nick Gardner answered
Hi, Setting your minimum SDK version to 14 should work fine, as as you've said, the tablets its failing on use SDK version 15. I would double check that you aren't using any libraries or frameworks that require a higher SDK version, as that might still be causing your app to fail. Barring that, please raise a contact us at https://developer.amazon.com/appsandservices/support/contact/contact-us while logged into your registered developer account so that we can look at any possible issues with this specific app. Thanks, Nick
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.