question

Arsham Manukyan avatar image
Arsham Manukyan asked

OpenGL version for legacy Kindle Fire devices

We've built game on Unity and are able run it on Kindle Fire HD(2012) without any issues. However, when trying to publish game through developer portal, we're getting following error Your APK manifest requires capabilities not present on this device. Learn More. android:glEsVersion = '0x20000'; device requires '0x0001000' We do not want to eliminate those original versions of Kindle Fires as we see lots of traffic from them on our other games.
fire tablet
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Wolf avatar image
Wolf answered
I just ran into this when posting an update. The documentation says that Fire supports OpenGL ES 2.0. I don't see any mechanism to report this as a bug... where would we do this?
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

justin avatar image
justin answered
Hi all, We are working on revising the messaging to be clearer at this point, but you should be able to submit and safely ignore the warnings when submitting your binaries. There should be no further immediate action required for supporting OpenGL ES 2.0 on your Kindle Fire device. Sorry for any confusion this may have caused you!
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.