question

vamsi-bosch avatar image
vamsi-bosch asked

While trying to install the eclipse plugin i am getting a error

when i try to install the eclipse plugin ' http://developer.amazon.com/eclipse", it says the url is invalid
fire tablet
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Sujoy@Amazon avatar image
Sujoy@Amazon answered
Hi Vamsi, Thank you for posting. Could you please let us know which eclipse plugin you are trying to install? How do you get the url " http://developer.amazon.com/eclipse"?
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

vamsi-bosch avatar image
vamsi-bosch answered
I followed the process mentioned in the below link : https://developer.amazon.com/sdk/fire/eclipse-plugin.html#Installing The section in that link is "Installing the Amazon Mobile App SDK Eclipse Plugin"
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

vamsi-bosch avatar image
vamsi-bosch answered
This is the error i am facing : sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Bipin@Amazon avatar image
Bipin@Amazon answered
Please accept the certificate while installing, the amazon eclipse plugin
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Venkat@Amazon avatar image
Venkat@Amazon answered
Screenshots attached.
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

vamsi-bosch avatar image
vamsi-bosch answered
As soon as add the website, it gives me this error.
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Bipin@Amazon avatar image
Bipin@Amazon answered
Hi Update java in the system to latest and install the bundle https://developer.amazon.com/sdk/fire/setup.html#InstallingAndroid Is the system under any firewall, In Eclipse IDE, select “Window –> Preferences” Preferences box left side, choose “Network Connections”. Select “Manual” from Action Provider drop down list Select Http in the List and click “Edit” button Fill in the proxy server host and port number, if it needs credentials - fill in the username and password if any. As it is not able to find the certificate, you need to install the certificate for validation. https://blogs.oracle.com/gc/entry/unable_to_find_valid_certification
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

vamsi-bosch avatar image
vamsi-bosch answered
Dear Bipin, I tried all the 3 steps, even it says amazon certificate is added to my keystore chain. Still the problem remains. As in the above two steps, I am able to run Amazon Emulator & install apps. Even my android apps works fine on the emulators
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Bipin@Amazon avatar image
Bipin@Amazon answered
Hi Vamsi I use the java version java version "1.7.0_25" Java(TM) SE Runtime Environment (build 1.7.0_25-b17) Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode) and followed Video: Amazon Mobile App SDK Eclipse Plugin http://www.youtube.com/watch?v=vg4X-8nYBbg?hl=en_US&modestbranding=1 The plugin was installed validating the amazon certificate successfully. In your case there is a problem with cacerts (example : C:\Program Files\Java\jre7\lib\security\cacerts) in validating the certificate. try with latest jre. If the problem still persists. Contact us( https://developer.amazon.com/help/contactus.html)
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

vamsi-bosch avatar image
vamsi-bosch answered
I installed JDK version 1.7.0_25 & JRE version 7. I downloaded InstallCert.java & ran the command Java installCert developer.amazon.com, but its giving me a error.
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.