chris avatar image
chris asked

Alexa iOS voice service -> Alexa Skills Kit failure.

As of December 11th our Alexa implementation worked perfectly. After successfully Logging in With Amazon, we were able to query Alexa with our skills kit specific questions in our iOS Alexa Voice Services product. That audio file was then successfully posted, our Alexa Skills Kit was consulted, our Amazon Lambda files were used, and the proper response was returned through Alexa to our app. Currently this no longer works. We are still able to Login With Amazon and query Alexa, but none of our Alexa Skills Kit skills are used. The only responses we are able to get from Alexa are her token responses. While debugging we used the Java Demo app(Amazon Provides) with our Alexa Voice Service product info to obtain a Amazon Access Token. We then used the access token obtained in the Java Demo app in our iOS app. Using this access token for our audio file HTTP Post the process again worked perfectly. Thoughts?
alexa voice service
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

elstryan@Amazon avatar image
elstryan@Amazon answered
There is another thread that captures the answer to this well ( I'll also post the answer here for completeness: Hi Chris, It does indeed mater what amazon account signs in. Skills are enabled per end user account - not per AVS device i.e. per user that logs in to the Login With Amazon screen, not per app APIkey/bundle id. Can you try the following to help us debug: 1) On your iOS device sign in with an amazon account and then fetch down an access token. 2) Using this exact same amazon account go the 3) Make some requests on your iOS device to Alexa and verify that you can these exact requests on For example: if you ask for a joke you should see text corresponding to what you spoke as well as Alexa's response. This way we can be sure that everything is hooked up as we expect. Next: on navigate to the skills tab and ensure that the skills you are looking for are enabled. Try doing a disable and then enable if they are. Let us know if this works. Thanks, Ryan
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.