article

Amelia@Amazon avatar image
Amelia@Amazon posted

How to fix library crashes with Aviary

Summary

Apps using the Aviary SDK may crash with the following exception;'java.lang.NoSuchFieldError: no "I" field "mNativeBitmap" in class "Landroid/graphics/Bitmap;" or its superclasses' on Android 5.x devices.

Resolution

The latest aviary SDK both for Android studio and Eclipse are available at Aviary web site. They released their latest update specifically to support Android 5 devices . So if you are using the Aviary SDK, please upgrade your library within your apps in order to support the latest Android devices.

The latest version of aviary SDK is available at: https://developers.aviary.com/docs/android

For more information about Aviary latest version 3.6.5 changes, please refer the below link. https://developers.aviary.com/docs/android/changelog

Keywords: Aviary, Library, NoSuchFieldError, BItmaps

KB_0009

androidlollipop
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Article

Contributors

brizzlebrazzle contributed to this article