question

coloradotex avatar image
coloradotex asked

Alexa Occasionally tells me "Hmmm........ Not Responding"

We have a smart home skill running with our home automation devices/hub and working very well. However, every couple of days, we have a situation when we tell Alexa to control a device (Alexa, Turn on Kitchen Lights), she responds with a message "Hmmm..... Kitchen Lights is not responding". We'll try to control other devices then and get the same message for those devices. However, she always recovers on her own - if we wait some number of minutes (undetermined and not sure if there is a set time), and we try it again, it works fine - Alexa responds "OK" and the devices perform the desired action.

We have two systems setup for development, using different accounts, different Echo devices, and different gateway devices (our hub). We're seeing this on both systems but not simultaneously. If we get this message on one system, we then test on the other system and the other system is working fine. Both systems use the same oauth authentication server, and the same cloud. So, there doesn't appear to be any problem with our cloud or authentication server as the other system continues to operate properly. When this occurs, we verify that the Echo device has access to the Internet (Alexa, what's the weather, etc) and we can access our hub gateway device through our cloud server. So, all of the individual pieces seem to be working. We have a handful of beta testers helping us test and they are seeing this issue also.

In doing searching online, we're seeing this issue being raised by quite a few posters. There is a very current thread on the Insteon forums where they are seeing almost the identical issue we're seeing and there were some posts indicating that Amazon was acknowledging a problem and working on a fix and that it impacted many protocols and not just Insteon.

http://forum.insteon.com/forum/main-category/insteon-products/insteon-hub/95732-alexa-integration-issues/page2

We have seen this issue intermittently for several months, but it seems to have gotten much worse recently. One poster suggested it got worse after the update to the Alexa app that provides control for individual devices.

Another post indicated that using similar names for multiple devices can lead to issues. For example, having Kitchen Lights and Bedroom Lights might confuse the system or having Kitchen Overhead and Kitchen Cans might confuse the system. I'm highly doubtful of that as I've tested with networks that have multiple devices called Lights - Kitchen Lights, Guest Lights, Bedroom Lights, Loft Lights, etc, and it seems to handle these just fine (when not in the "not responding" situation). But, does anyone know if this is a known issue or not?

We can fix each instance when it occurs by disabling the skill, re-enabling, relinking and doing a device discovery. Then, it works well for another couple of days. I tried doing a Forget all Devices from the Alexa website, then doing a Device Discover, without disabling / enabling the skill but that didn't clear it up.

We are trying to troubleshoot this issue, but it's very difficult, as it happens rarely (every couple of days) and it corrects itself after some small amount of time. While we continue to try to catch it and see if there are any issues at that time with authentication, etc, we're hoping Amazon might be able to shed some light on this.

Quite a bit of rambling here, but If there really is an issue with Alexa, could you provide us with some information, please? If you're not aware of an issue with Alexa that would cause this situation, can you provide any tips or guidance as to where we could look in order to determine a resolution?

Has anyone else run into this and do you have any guidance?

Thanks so much.

alexa smart homeamazon device messagingdevices
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

coloradotex avatar image
coloradotex answered

An update to this, since we never received a response from Amazon. It's been a hard one to figure out, as it happened so infrequently, but we determined we had a problem with how we were responding to an error message within the authorization process when there was a problem with an expired token. We believe the problem is resolved so issue is closed as far as we are concerned.

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

RichSNJ avatar image
RichSNJ answered

I have my house completely done with Insteon using an Insteon hub. I occasionally get the same problem you're having, and almost always it is resolved by telling the echo in question to "rediscover", 20 seconds later it works fine. The only time I've not had that resolve it was when the Insteon website was down. I believe this is on the Echo or the Echo skill end because all the Insteon features seem to work ok either locally or though my phone app without fail.

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

newuser-2496bf3e-e4fd-41f5-964d-a7af7a33c106 avatar image
newuser-2496bf3e-e4fd-41f5-964d-a7af7a33c106 answered

I have LIFX lights which can be operated from my Chrome taskbar, from a Windows 10 app and from the same(ish) app on an Android tablet. Although I can turn the lights on and off using any/all of these apps, Alexa responds with "Lights isn't responding. Please check its network connection and power supply".

In the Alexa tablet app, I can see the light but when I tap to turn it on or off, I get "Waiting for LIFX..." for a couple of seconds and then nothing. At all. The lights work using the light switch, using the apps and using the browser extension so this HAS to be an Alexa problem. I don't know what the problem IS or how to troubleshoot it but considering coloradotex's post was originally from early December 2017 and it's now late July 2018 I'd say Amazon have a lot to answer for. They haven't responded at all, even though this is THEIR forum!

The "Skills" or "Smart Home" sections in the Alexa app are often unavailable (just 3 blinking dots and no page opens). No explanation why Alexa can't turn the skill on itself if needed, but she tells ME to do it even though I don't have access to the app. Not really labour-saving!

When it works, it's great! "Alexa turn the lights off" does exactly that in less than a couple of seconds. Unfortunately, it doesn't always work and the time I waste trying to fix the problem completely undoes any benefit I've had from it. I've only had the Echo Dot for 24 hours, the lights have worked a few times (I've tested/played with it a lot) but failed to work much more often. A success rate of maybe 1 time in 5 :(

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.