question

Alex avatar image
Alex asked ·

Echo show "camera isn't responding"

Hi..

it is my sencord question.

I already asked to Amazon customer service but no response. :(

I made a testing environment with rtsp camera + live555 proxy server + stunnel.

I succeed the communication until RTSP DESCRIBE message.

but no any more message from ehco show. i tryied to dump the packers.

echo show sent FIN/ACK packet then disconnected.

FYI, it a my lambda response message.

{ "event": { "header": { "messageId":"69c50a8e-d7f2-4dcf-aa85-e28c63885770", "namespace":"Alexa.CameraStreamController",

"name":"Response",

"correlationToken":"AAAAAAAAAAAn4Clhf7r/AR.....",

"payloadVersion":"3"

},

"endpoint": { "endpointId":"0c001100002" },

"payload": {

"cameraStreams":

[ {

"uri":"rtsp://mydomain.com:443/proxyStream",

"expirationTime":"2017-12-31T16:20:50.52Z",

"protocol":"RTSP",

"resolution": { "width":1280, "height":720 },

"authorizationType":"NONE",

"videoCodec":"H264",

"audioCodec":"G711" }

],

"imageUri":"https://s3.sammachin.com/loading.jpg" }

}

}

I changed my real camera URL only.

I think the SSL connection is no problem because i can receive the DESCRIBE message.

and it is the response of DESCRIBE request.

RTSP/1.0 200 OK

CSeq: 1 Date: Sat, Nov 18 2017 01:25:22 GMT

Content-Base: rtsp://mydomain.com:443/proxyStream/

Content-Type: application/sdp

Content-Length: 514

v=0

o=- 1510968235968441 1 IN IP4 10.117.224.138

s=LIVE555 Streaming Media v2017.10.28

i=LIVE555 Streaming Media v2017.10.28

t=0 0

a=tool:LIVE555 Streaming Media v2017.10.28

a=type:broadcast a=control:*

a=range:npt=0-

a=x-qt-text-nam:LIVE555 Streaming Media v2017.10.28

a=x-qt-text-inf:LIVE555 Streaming Media v2017.10.28

m=video 0 RTP/AVP 96 c=IN IP4 0.0.0.0 b=AS:50

a=rtpmap:96 H264/90000

a=control:track1

m=audio 0 RTP/AVP 97

c=IN IP4 0.0.0.0

b=AS:50

a=rtpmap:97 PCMA/8000

a=control:track2

The response time is not over 1 second now.

what's wrong? i spent so many time to dubug this issue.

Please let me know some guide.

Thanks,

Alex

echo showvideo skill api
2 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

You ever solve this? I can't. I can't even see why my rtsp is erroring out within Echo Show. I have no way to debug it. The developer site under test just says 'cameras are not supported on this device' when I try.

0 Likes 0 ·

Hello Will,

Can you share skill id with us I will take a look?

0 Likes 0 ·
Mykroft avatar image
Mykroft answered ·

Any chance you could share any of the details or source? I am trying to do exactly this and you are much further along.

I feel you are right in that you would not be communicating at all if it were a TLS issue. So stunnel appears to be a good option.

I'm not going to be much help here, but...

Can VLC or another client see video through the live555 proxy? I mean it almost just seems like a proxy error or proxy configuration problem.

Can VLC or another client see video directly to the camera?

Here, https://developer.amazon.com/docs/smarthome/build-smart-home-camera-skills.html , it sounds like you are required to spell out height and width separately?

Does Discovery work?

I don't have enough experience to really help you, but I'm interested in figuring this out, so I can try to keep the conversation going...

I am attempting to use a SnapAV Luma NVR, but not very optimistic. This custom stuff is hard work.

10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

KAIYIN@AMAZON.COM avatar image
KAIYIN@AMAZON.COM answered ·

Replied in the contact-us as well. Try set authorizationType" from "NONE" but "BASIC".

1 comment
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Did anyone ever figure this out? No matter what I do I always get 'Hmmmmm.....Kitchen camera is not responding'. My RTSP stream is fine via VLC

0 Likes 0 ·
newuser-81079dd9-74e3-40ba-a8a1-783ce9de1ee9 avatar image
newuser-81079dd9-74e3-40ba-a8a1-783ce9de1ee9 answered ·

Have you figure this out?

10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

newuser-74f6365d-fd45-4da7-b5b9-b3e0fb9a92bc avatar image
newuser-74f6365d-fd45-4da7-b5b9-b3e0fb9a92bc answered ·

Hi,Have you solved your problem?I have the same problem,but my SSL is fine,however,I'm using SSL_read and it returns 0,I can't read anything,Should the server send something to echo show before using SSL_read?Thanks.

10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.