question

someguyontheinternet avatar image
someguyontheinternet asked

DNS seems broken on Dash buttons

Seems the Amazon dash button does not like/recognize the response from common internal DNS servers, it just tries over and over...

09:22:03 time-c.nist.gov. type A
09:22:03 time-c.nist.gov. type A
09:22:04 time-c.nist.gov. type A
09:22:04 dash-button-na.amazon.com. type A
09:22:04 time-c.nist.gov. type A
09:22:05 dash-button-na.amazon.com. type A
09:22:05 dash-button-na.amazon.com. type A
09:22:06 time-c.nist.gov. type A
09:22:07 dash-button-na.amazon.com. type A
09:22:08 time-c.nist.gov. type A
09:22:09 dash-button-na.amazon.com. type A
09:22:10 time-c.nist.gov. type A
09:22:11 dash-button-na.amazon.com. type A
09:22:13 time-c.nist.gov. type A
09:22:14 dash-button-na.amazon.com. type A
09:22:17 time-c.nist.gov. type A
09:22:18 dash-button-na.amazon.com. type A
09:22:21 time-c.nist.gov. type A
09:22:22 dash-button-na.amazon.com. type A
09:22:25 time-c.nist.gov. type A
09:22:26 dash-button-na.amazon.com. type A
09:22:30 time-c.nist.gov. type A
09:22:31 dash-button-na.amazon.com. type A

But, when setting my network's DNS to 8.8.8.8 instead of the internal server it works fine. Why is this?

If Amazon dash button is going to pickup the DNS server from DHCP, which is commonly the router, or company internal DNS server (and where other DNS servers will be explicitly denied for security reasons) then it should take the response. I tried for hours to activate Dash buttons in a company before realizing the reason it would not, DNS request are not blocked, but it doesn't seem to "like" the response from corporate DNS servers.

debuggingdevicesdash replenishment service
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Levon@Amazon avatar image
Levon@Amazon answered

Hi someguyontheinternet,

Thanks for posting. Your statement above is not true. The Dash button does not have any preference of DNS servers by itself. It will indeed take the DNS servers mentioned in the DHCP reply / ack from the DHCP server (router in most cases) and use that to perform all the DNS activities. We are not sure how you determined that the dash device did not "like" the response. Just to be double sure we tried the experiment on our own device using a router connected to the Amazon corp network and tweaked the router to use Amazon's specific DNS servers. The dash button was able to register just fine and we captured the whole Wi-Fi over the air transaction to confirm the DHCP reply from the router and the button actually using that entry to look up dash registration server and NIST server etc. Thanks!

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.