question

Heavenly avatar image
Heavenly asked

Interstitial and banner ads not loading. "Server message: no results"

I have implemented Mobile ads in my app according to the quickstart guide.

I'm using banner and interstitial ads.

When I use this construction call for the banner:

banner = new AdLayout(this, AdSize.SIZE_1024x50);

I get no message from server. Ad doesn't load. If I remove the ad size specification (so that it autosizes), the ad fills. However I need the 1024x50 specification!

The interstitial ad doesn't load at all. My implementation is identical to the one in the quickstart guide.

Same error message: Server message: no results. Try again in 10 seconds.

I should mention that on my first test both of the ads loaded, but that was the only time that happened.

mobile ads
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Levon@Amazon avatar image
Levon@Amazon answered

Hi Heavenly,

Welcome to dev forums and thanks for posting! The problem you described is often because of the container size, please see the following Knowledge Base articles and the Frequently Asked Questions for more details:

https://forums.developer.amazon.com/articles/18195/disabled-app-changes.html https://forums.developer.amazon.com/articles/18197/why-am-i-receiving-no-fill-errors.html https://forums.developer.amazon.com/articles/18196/why-is-my-fill-rate-dropping.html https://developer.amazon.com/public/apis/earn/mobile-ads/docs/faq

3 comments
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Never mind, I fixed it. For some reason, I thought it was a good reason to delete the Google Play Services dependency in my build.gradle (app) file. After readding the dependency, ads finally load properly.

1 Like 1 ·

Thanks for sharing your solution with the developer community. Cheers!

0 Likes 0 ·

Thank you for your help Levon. I inspected my app thoroughly after reading the articles you have sent me carefully and the ads still don't load. The test ads always load, but the real ads don't especially the interstitial ones. What really puts me off track is that when I tried to fix the bug today, I did receive real banner ads for the first time around. However on the next run they didn't load again. On my banner I'm using 1024x50, MATCH_PARENT on width and WRAP_CONTENT on height. I completed the Service Tax Identity interview like a week ago and just to be sure I also completed the Royalty Tax Identity Interview. Really unsure where to go from here.

0 Likes 0 ·