question

AppyNation Ltd. avatar image
AppyNation Ltd. asked

How do we know which version of AmazonAd.framework to use with Unity plugin?

We can download the zip for Unity from https://developer.amazon.com/sdk-download which contains the AmazonMobileAds package. The latest version is 1.0 (May 4, 2016). But this package doesn't work on its own - it also requires the AmazonAds.framework in order to build in Xcode.

The AmazonAds.framework itself can be found in the AmazonMobileAds component of the iOS zip at the same download page. Its version is 2.2.15 (Aug 30, 2016).

Is this recent framework compatible with the older plugin? There seems to be no documentation explaining this.

mobile adsiosunity
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Levon@Amazon avatar image
Levon@Amazon answered

Hi AppyNation,

Thanks for posting! Your observation is correct. At the moment, SDKs have different versions on different platforms, so for example Mobile Ads has different version numbers on Android, iOS, and Unity. Despite of that, an ad-based app using the latest Unity plugin should build in Xcode with the latest (even though different) version of Mobile Ads for iOS. Thanks!

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.