question

Thomas England avatar image
Thomas England asked

Unknown Failure (-1,-1,-1,-1) registering espressif ACK

I'm having an issue registering the ACK module with the Alexa app in the "Set Up an ACK Development Kit" tutorial. A few weeks ago I successfully did this, and I also successfully registered the development device in the following "Prototype Your Product" tutorial for the Hello World app(which included uploading a custom product provision file). Going back now though, I can't seem to get the basic smart light tutorial working. How can I get the default firmware flashed back onto the ACK module? Here's a description of some of the solutions I've tried based on other posts:

  • I've deleted the prior connected development device previously registered on the Alexa app
  • Using latest version of Alexa App on iOS, I've tried signing out/back in, and deleting/reinstalling the app
  • Using ModuleUtility_5.1.43.0 I successfully updated the firmware to __Version 0068 (3.307006820.build2202180044.01)__
  • I connected to the ACK module directly through USB in the terminal with "screen /dev/tty.usbserial-1450 115200"
  • with the cmd “devkit factory_reset_to_module” it successfully performed a factory reset, but what follows is an error after booting slot # 2 of 2 slots, with the logged message "W DEVICE_TYPE read failed -8"
  • Tried getting the devkit get_device_type but it returns nothing(null value)


Is there any obvious diagnosis to this problem based on the provided info?

ack
1 comment
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

(-1:-1::-1:-1) is a generic error code, when alexa app unable to detect your module for multiple reasons. If you use "devkit factory_reset_to_module" that will delete all the product configuration and user data in the module, you have to re-provision the module(from step-2) with an ACK product, use the below guide for prototyping your product

https://developer.amazon.com/en-US/docs/alexa/ack/steps-to-prototype-a-product.html


For FW update https://developer.amazon.com/en-US/docs/alexa/ack/module-utility-cli-reference.html#updatemodule

0 Likes 0 ·

0 Answers