question

池戸 憲夫 avatar image
池戸 憲夫 asked

Doesn't complete the setup process of ACK device.

I made original circuit board that using esp32 pico v3 zero and test it to make original device using ACK.

On the test, I use tutorials "Prototype Your product"(https://developer.amazon.com/ja-JP/docs/alexa/ack/create-virtual-product.html)

But Step5, when I scan QR code, Alexa app show this view immediately. And it doesn't show wifi settings.

img-8627.png

Of course, I already finished Step1 ~ Step4 completely. And I confirmed the system has the BLE data.

img-f005e1208e92-1.jpeg

Is it App's bug? or Error of the original circuit board?

My development environment is...

- iPhone12 pro max , iOS:15.1.1

- Alexa app version: 2.2.454039

- ACK module: ESP32-pico-v3-zero

- MCU: RP2040
Note: Original board is not connect the reset signal to MCU.

Another pin assign is same as arduino zero.

alexaappwi-fi setup
img-8627.png (282.0 KiB)
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Veera Manideep Guntupalli avatar image
Veera Manideep Guntupalli answered

In step5,

1) can you confirm, you choose "development device" and then "ACK" right?

2) can you make sure the Bluetooth device or the ACK module didn't timeout during the registration? you might have to restart the ACK module if Bluetooth times out.

https://developer.amazon.com/ja-JP/docs/alexa/ack/register.html

1 comment
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thank you for your reply.

I confirmed process again. 1) is incorrect in my process. I selected "Espressif".

When I have been choosed "ACK", set up process was completed!

0 Likes 0 ·