question

Alex Sensor avatar image
Alex Sensor asked

skill working on mobile app and test dev console but not on echo show 5

currently testing skills and none of them i do are working on my actual linked device Echo Show 5 (2nd Gen, 2021 release)

decided to do the "Hello world" skill in the dev console and it's working fine on the mobile app & test panel in the dev console, however it isn't working at all on my linked device. currently set it up with beta test (yes, everything is using the same email & the language/region is the same)

Things I've tried:

  • Using the mobile app to enable it
  • Testing it on the dev portal and mobile alexa (worked, but still not working on echo)
  • Factory resetting the Echo Show 5
  • Creating a new skill
  • Restarting the echo
  • Language is the same on everything as well as the region
  • Email is the same on everything
  • Disabling the skill and re-enabling it on the mobile app
  • WiFi is the same on everything
  • Changing the skill name & launch phrase

yeah so pretty much nothing is working

alexa responds with "Sorry, I couldn't launch it" when i say "launch [skill name/phrase here]"

other public skills are working, just not mine that i'm doing with the beta test feature

any help is appreciated, thank you.

alexa skills kitalexanodejsskills
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Andy Whitworth avatar image
Andy Whitworth answered

Have you checked that the dev version of your skill is enabled ? This doesn't always happen by default and can cause the issues you mention i.e. works in dev console but not on a real device.

Check the Alexa app, find your skill (the dev version) and ensure it's enabled.

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.