question

Cyndi_Yang avatar image
Cyndi_Yang asked

[FFS] Echo dot can not work with requested requested keys

@david@amazon Hello, plz take a look on here.
I am about to develop a switch with FFS feature.
Now I am in practicing ffs and try to implement ffs sdk to my project. I had faces sevrial issus can you give some advise on them?
test enviroment:
1. WSS C SDK version: 2.3.0
2. Echo Dot 3rd generation
3. platform: esp32

encounter problem:
1. After implement sdk to my switch project, I found my Echo dot can not provision network to my device as the hidden network that my device trying to connect is not match with the one Echo Dot generated. Could you tell me what happen and how to solve this issue?
The detail of my application process is as follow:

1) I requested the Device Type Identifiers from https://developer.amazon.com/frustration-free-setup/console/onboard/request-device-registration

2) About a week later, I received the email from FFS support team with DSS Public Key

3) I used the DSS Public Key to generate DAK and DHA keys and in the end I have obtained private_key.pem and certificate.pem from https://developer.amazon.com/frustration-free-setup/console/manage-daks?apid=ctw3

4) I replaced the keys with the newly generated pair and tried to connect Echo dot within 5 mins after setup.

5) Connection failed.

2. After failed to connect Echo dot, the demo try to connnect "simple_setup". If I used DSS Public Key I requested from developer portal and cert generated by DSS Public key. demo will failed at START_PROVISIONING. But if I use demo cert which provide by amey@espressif.com demo can run as expected and get wifi_crenditials from DSS server. I am not sure what did wrong, could you give some advise? why did I failed if I use my own DSS Public key will failed?

I had already send email to ffs-support@amazon.com but still not receive any response now.


device keysdk develop
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

0 Answers