question

Paphus Solutions avatar image
Paphus Solutions asked

App submission, 0+ Supported Devices, Samsung S6 is latest device??

I have been trying to submit our Android app to the Amazon App store for the last month.

The first attempt yielded "Install failed on all supported devices", with no other info, but after contacting support I finally got the logs and devices that it failed on and all were ancient devices like Kindle 2013. So I updated my manifest to require Android SDK 26, and now trying to submit I get "no supported devices". Looking through the devices the latest device listed is the very old Samsung S6??

Is the Amazon app store dead or something, why is an ancient device like S6 their latest supported device?? or am I missing something?

amazon appstore
10 |3000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Kunijordan avatar image
Kunijordan answered

Hello,

Thank you for posting comment in the forum.

For maximum compatibility with the devices, we suggest that you set a lower minSDKversion value preferably 19 or even lower.


Additional information on device compatibility:

https://developer.amazon.com/docs/app-submission/device-filtering-and-compatibility.html#evolving-api-levels

https://developer.amazon.com/docs/app-submission/troubleshooting-android-manifest-and-device-targeting.html


Best,

10 |3000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Paphus Solutions avatar image
Paphus Solutions answered

But it is 2021, your most recent supported device is from 2015??

The current Android API level is 30, 19 is very old, are you saying Amazon requires apps support API level 19??

10 |3000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.