question

St3ve avatar image
St3ve asked ·

ACK on ESP8266 NodeMCU v3 , Error 1003 in ModuleUtility 5.0.39.0

Hi,


i'm developing a prototype for an IoT lamp that should be released commercially in the upcoming future. I'm using the board ESP8266 NodeMCU v3.


I'd like to integrate Alexa basic controls for this lamp. The device should be able to get turn on and off from any location...using the alexa app or an Echo device ( if the user is at home ).


We are not a company, and we have no revenue


What's the best way to accomplish this? I found myself good with ACK, i even revisited the sample app to fit my basic needs for the lamp interaction.


But there is one little problem, i don't understand if it is a compatibility issue, or just the environment...when using the latest Module Utility for Espressif chipsets, i can list the available port, and it is not inUse... but i can't use deviceinfo on that port, i can't provision the device and i can't even flash the ACK_Firmware_0015 into the board. The error is still the same


Error 1003 : Error : Module did not respond correctly. Check port and module


I'm running Ubuntu 20.10 and Java 15.0.2


I even tried to do a factory reset of the board using esptool erase_flash but still i got the same error...


Could you please help me understand better this problem? I'd also really appreciate any suggestions regarding the possible implementations for this lamp... we also have a companion app for it running on Android. So... i really don't know what decisions to take at this point...


Thanks in advance!


EDIT:


As suggested by Karunish@Amazon i tried to downgrade my Java version to 8 ( later on i tried even 11) but the error still persists...

smart homelightsackcli
4 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Have you tried different versions of Java? Try using Java standard edition 8 or 11 for running Module Utility provisioning commands. Hope it helps.

0 Likes 0 ·
St3ve avatar image St3ve Karunish@Amazon ·

I tried with Java version 8 and 11 but still i have the same error... I'm posting the log file under /tmp ...

0 Likes 0 ·
St3ve avatar image St3ve Karunish@Amazon ·

Is the ESP8266 NodeMCU v3 compatible at all with ACK?

0 Likes 0 ·

THIS IS THE LOG FILE UNDER /tmp , it is the same for every command, since the error is the same...


13:23:30:1613046210852 | 0 | INFO | com.amazon.ack.utility.ApplicationInfo | alwaysLogInformation | 1 | Utility Version: 5.0.39.0 13:23:42:1613046222440 | 1 | SEVERE | com.amazon.ack.handlers.SerialPortAwareActionHandler | handleAction | 1 | Unable to read the device version information. com.amazon.ack.exceptions.AckModuleUtilityException: Error : Expected three lines of non null output for version command.      com.amazon.ack.commands.VersionExecutor | retrieveFirmwareVersionIfNeeded |  line: 80      com.amazon.ack.commands.VersionExecutor | getFirmwareVersionInfo |  line: 57      com.amazon.ack.handlers.SerialPortAwareActionHandler | handleAction |  line: 34      com.amazon.ack.CliActionHandler | handle |  line: 163      com.amazon.ack.main.AckModuleUtilityMain | main |  line: 61      com.amazon.ack.main.AckModuleUtility | main |  line: 17 13:23:42:1613046222919 | 2 | SEVERE | com.amazon.ack.CliActionHandler | logException | 1 | Error: com.amazon.ack.exceptions.AckModuleUtilityException: Error : Module did not respond correctly. Check port and module      com.amazon.ack.handlers.SerialPortAwareActionHandler | handleAction |  line: 42      com.amazon.ack.CliActionHandler | handle |  line: 163      com.amazon.ack.main.AckModuleUtilityMain | main |  line: 61      com.amazon.ack.main.AckModuleUtility | main |  line: 17 
0 Likes 0 ·

1 Answer

Veera Manideep Guntupalli avatar image
Veera Manideep Guntupalli answered ·

ESP8266 MCU based modules is not supported by Alexa Connect Kit. If you are developing a prototype, please refer to Obtain the ACK development Kit document

If you are a device maker interested in moving forward with a project, contact the Alexa Connect Kit team at ack-apply@amazon.com with relevant information.

https://developer.amazon.com/en-US/docs/alexa/ack/ack-support.html#contact-us-about-your-project

10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.