question

newuser-78cca2ac-6e09-4361-acc6-c020a1498e69 avatar image
newuser-78cca2ac-6e09-4361-acc6-c020a1498e69 asked ·

Long delays after cancelling or making a purchase via the IAP purchase UI?

We're testing a new implementation of subscription billing using the IAP library and we are seeing very long delays before the result callbacks come back from the IAP library. E.g. user starts purchase flow UI and hits cancel.

We would expect a quick ( "right away" ) callback response, however, it takes a few seconds ( 5-10 seconds ) which seems way too long. When testing in Sandbox mode with the test app, there is no delay, these long delays happen only when using published apps in live testing. Is this a known issue?


The delay I'm talking about happens e.g. after the user cancels the Appstore's UI, and before the callback with the result ( "e.g. user cancelled") happens.

Will our users experience this sort of delay once the app is released as well? Or is this maybe only happening during LiveTesting?

Is there anything we can do about this?

Thank you.

iapappapps
2 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

After investigating this a bit more thoroughly, it seems that the time between dismissing the Amazon Purchase popup UI and the callback on .

PurchasingListener.onPurchaseUpdatesResponse

is ~ 10 seconds.


Not sure exactly what to make of this, but it feels like this is some artificial delay or timeout.


0 Likes 0 ·
Jacek avatar image Jacek newuser-78cca2ac-6e09-4361-acc6-c020a1498e69 ·

Hi, I think it is related to another bug reported here.

Basically, Amazon screwed up IAPs on about Nov 1st with FOS update at that time. Although, that reported issue is about web apps, I don't think it really matters, as the apks produced for our apps were built by Amazon few months before that and were working fine (and all libs specific to web apps IAPs are in those apk).

Over a week ago, there was some movement by Amazon to understand the problem (looking at our server logs) and there were few smaller updates, but IAPs still don't behave the same as before that FOS update (our old code that Amazon is using for testing still doesn't work).

I have just copied a simple code over one of our production app, and I don't see that callback for purchase request at all. On the other hand, other calls seem to be working fine (although, still not as before). So this potentially confirms what you see with that onPurchase... callback.

At least a couple of us (Sam is another developer) did a work-around for all but getUserData calls, by calling an extra getUserData after _each_ other IAP call. That extra call is flushing stalled callbacks, if any and is harmless if nothing is stalled. Although, IAP behavior is rather screwed up.

Also, your interpretation of how that callback 'should' work may not be correct. It is a callback, so really you cannot tell when it will be triggered. It may also be that the user will kill the app before that callback gets triggered. So, yo would need to potentially be more flexible about how you handle it. (I know, this time it is 10s all the time, so it is for sure a screw up, but...)

Since Amazon is drooling over this problem for more than a month, it is hard to tell when this bug will be addressed.

And no, this is not a specific issue with your app, it is a bug with the latest Amazon IAP implementation.

Thanks, Jacek

0 Likes 0 ·

1 Answer

Sheldon@Amazon avatar image
Sheldon@Amazon answered ·

Hello,

Thank you for posting on forums.

Because this is regarding a specific issue with your application, we aren't able to respond in the public forum.

We see that you have already contacted our support team, and they should reply to you soon.

Regards,

Sheldon



2 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

@Sheldon@Amazon

No, this is not an app specific issue, rather this is already a well known Android IAP bug that Amazon needs to fix ASAP. So, please escalate this issue, as looks like it is related to broken IAPs for web apps (or rather the root cause for it).

If you have problems with it, please speak with @Levon@Amazon as we exchanged already some info about this problem about a week ago.

Thanks, Jacek

0 Likes 0 ·