question

Jimena avatar image
Jimena asked ·

Getting port of USI Development board with listports command outputs inUse: false

Hello!


I’m trying to provision a module following the tutorial at https://developer.amazon.com/es-ES/docs/alexa/ack/steps-to-provision-a-module-ack-managed-services.html


I’m trying to determine the serial port that corresponds to my module (I’m using the USI Development Kit), in order to do that I use the listports command from the Module Utility CLI. The output is:

Serial ports available:
COM3 (inUse: false)

If I understand it correctly it should be inUse: true. Right now if I try to execute any other command on that port I get the following error (Error 1003: Error : Module did not respond correctly. Check port and module)


I tried every USB port of the development kit (both of the arduino zero and the debug port of the USI MT7697H board). I also tried removing the caps of the jumpers of the USI MT7697H board. But I get the inUse: false output in every scenario.


Do I need to upload a specific code to the Arduino Zero board that allows the provision?


Thanks and Regards

ackcli
3 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

You do not need Arduino Zero board to be connected to ACK Module to perform product provisioning. Can you try disconnecting ACK Module from Arduino Zero, connect ACK Module Debug Port through UART to your computer and try listing ports using Module Utility?

Make sure you do not have any active connective to ACK Module through Arduino IDE or serial connection.

You can refer the Module Utility CLI reference guide for more information.

0 Likes 0 ·

I also tried that, disconnecting the Module from the Arduino, connecting the Debug port to the computer and using the listports of the Module Utility. But the result is the same, the device is found on COM3 but the inUse flag is set to false so I cannot execute any other command.

I also don't have any other connections to the module.

Do you know what's the UART baurate of the module?


0 Likes 0 ·

I found the solution! I used the devkit command

devkit factory_reset_to_module

And when I tried to re-provision the module it worked.

I didn't know about all this other commands available to interact with the module. Is there a reference guide for this commands?

0 Likes 0 ·

0 Answers