question

Junda avatar image
Junda asked

Error when using ask smapi import-skill-package

I tried creating an Alexa-hosted skill and configuring it further to implement custom tasks. After much digging, I realised that I needed to modify the skill package and export it back to the hosted space.

As a result, I tried zipping my skill-package, uploading it to a S3 url, creating a presigned URL, and run the following command

ask smapi import-skill-package --location <presigned_url> --skill-id <skill-id> -p <profile> --if-match <etag>


However, when I inspect the import status via "ask smapi get-import-status", it kept on showing me a "skill.json is not in package" error. I tried re-uploading a new zipped file, and check multiple times but still faced the error.

As this is my first time using the import-skill-package, I am unsure why this error is occuring. I attempted to use the eTag both from "ask smapi get-interaction-model", as well as the eTag in the S3 bucket, but both still yielded the same error.

Appreciate if I could get some advice on the following. My skill id is "amzn1.ask.skill.a15bbdcf-54b8-481c-bd7c-a052339e0c97" and the error message can be seen in error_msg.txt.

alexa skills kit
error-msg.txt (1.4 KiB)
1 comment
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thanks for sharing it

0 Likes 0 ·

0 Answers