ritresh avatar image
ritresh asked

Proactive event api returning 403 "No enablement for clientId : ..., userId: ...

Team I am facing issue while invoking proactive event api. Can you please suggest what wrong with my request body ?

Skill ID :




Content-type: application/json

Authorization: Bearer <token>

Request Body


"timestamp": "2020-05-29T17:27:29.150Z",

"referenceId": "SampleReferenceId1590773249151",

"expiryTime": "2020-05-29T18:27:29.150Z",

"event": {

"name": "AMAZON.OrderStatus.Updated",

"payload": {

"state": {

"status": "ORDER_SHIPPED",

"deliveryDetails": {

"expectedArrival": "2020-05-31T18:30:00.000Z"



"order": {

"seller": {

"name": "localizedattribute:sellerName"





"localizedAttributes": [


"locale": "en-US",

"sellerName": "Delivery Owl"



"locale": "en-GB",

"sellerName": "Delivery Owl UK"



"relevantAudience": {

"type": "Unicast",

"payload": {






{"type":"Forbidden","message":"No enablement for clientId: amzn1.application-oa2-client.74a0b8576ffe4b4fb229b8eb997dc988, userId: amzn1.ask.account.AEYETKDHHC5A4W3Q5IVAN4U2PKN7EUNU3WMKW7ZMEOTA5ZTAXE4Y2TDPOSTYZ676XHSFFT6AWBVZAD7A4T7QF6GFL2VJ2YRDDZYNDV2HUAM25DXHSFUTWSXLPD5HCKQLC473T4EPNOFQGDF36B63P32NYQV7USA3DOTL2DFRAF6PCWLBD4NDH6CHSYU4KHMYHBQSPELHKECFSQQ"}

Event tried to invoke

Still getting same 403. Please help in understanding the reason.

Thanks in advance !!!

proactive events
1 comment
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Did you get an answer?

I am getting the same error though I have activated notifications both as a developer (in skill.json and by deploying the skill) and as a user (on by allowing them). This error also popped up when I tried the feature AMAZON.MessageAlert.Activated (in Unicast):

{"type":"Forbidden","message":"No enablement for clientId: amzn1.application-oa2-client.xxxxxxxxxxxxxxxxxxxxx, userId: amzn1.ask.account.XXXXXXXXXXXXXXXXXXXXXXXXXX"}

Also, when I send a AMAZON.MessageAlert.Activated (in Multicast), I get a 202, but nothing appears on my EchoShow or my Alexa app...

Thanks in advance for your answer!

0 Likes 0 ·

0 Answers