question

Fish avatar image
Fish asked

Unknown Failure (-1,-1,-1,-1)

I am having issues with the final registration to the Alexa app. I have been able to connect with the development kit as shipped and able to connect when i edited the config file a few times, but it is very inconsistent.

ack
1 comment
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Karunish@Amazon avatar image Karunish@Amazon commented ·

Could you provide more details.

  • Have you created a product from ACK developer console and trying to register that product on development kit? . If yes, what capabilities have you setup on the product created?
  • Which version of Module Utility are you using for product provisioning?
  • Are you using Alexa App on iOS or Android ? Have you been able to register successfully even once?
  • Have you tried signing out of Alexa App, re-login and tried re-registration?
0 Likes 0 ·
DanM avatar image
DanM answered

I am getting the same failure when I try to connect to the Dev Device using Alexa App. I am trying to connect the device to a new WiFi AP by going through the barcode setup, but the app cannot connect after scanning the barcode. It appears that the ACK module is not beaconing. Is there a way to delete the current registration info using the JAVA CLI utility?

1 comment
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Manideep@Amazon avatar image Manideep@Amazon commented ·

I would recommend re-provisioning the device by following "devkit" commands either using putty for windows / screen for mac machines. Please note the baud rate for ACK Modules is 115200. So your command will look like

For MAC

screen <serial port> 115200

1) Factory reset the module using

devkit factory_reset_to_module

2) Re-provision the module by following "Steps to Provision a Module" documentation, make sure the device is provisioned successfully from the output displayed.

3) Register device by generating barcode

0 Likes 0 ·
DanM avatar image
DanM answered

Ok, I have finally solved my problem by connecting a USB cable to the debug port on the ACK shield board (with the Arduino still connected).

This port enumerated as serial comport #11 on my PC, but yours may differ. The trickiest part was figuring out the baud rate. Turns out it is 115200. I suppose I could've looked through the sample code or the libraries to figure that out, but really this should be documented somewhere on the ACK developer site in the specs.

Anyway, once I figured that out, I used the command to re-register, which is "devkit start_registration user_guided". Then continue with normal registration in the Alexa app. If that doesn't work, there is also a cmd to clear out the registration info which should achieve the same result in a few extra steps. Also there appears to be entire menu of debug port items that look pretty useful but are not documented anywhere (at least that I could find).

$ ?

version - Prints version information

wifi_network - Wi-Fi network management operations

devkit - Module control and state operations

crypto - Cryptography-related operations

simple_setup - Wi-Fi Simple Setup operations

otw - Over-the-wire firmware update operations

logging - Logging operations

reboot - Reboots the module


It would be really nice if you guys could document this somewhere on the ACK developer website. I didn't find it by a browser search and there is really no reason for it not to be there. I was able to update the FW using the Java utility. That, on the other hand, seems to be fairly well documented. Hope that helps the others.




10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.