question

Jonathan Horniblow avatar image
Jonathan Horniblow asked

Obsolete version of node in hosted skills?

Amazon is frequently warning about the imminent EOL of node 8.10, but I just noticed that hosted skills are running on that old version, and I just don't see a way to bring it up to the current version, in fact ONLY the old version is supported

https://developer.amazon.com/en-GB/docs/alexa/hosted-skills/build-a-skill-end-to-end-using-an-alexa-hosted-skill.html#programming

https://developer.amazon.com/en-US/blogs/alexa/alexa-skills-kit/2019/11/nodejs-8-10-end-of-life-how-to-migrate-your-nodejs-alexa-skill-lambda-to-nodejs-10x

Hmmmm...

node_jsnodejsask sdkhosted skillhosted-skill
1 comment
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Bumping this back up. This line "Once you choose a runtime for a specific skill, it cannot be changed. " from the alexa-hosted skill spec is worrisome.

0 Likes 0 ·

1 Answer

Anand@Amazon avatar image
Anand@Amazon answered

Hey @Jonathan

Please refer this blog which talks about migrating alexa hosted skills from Node.js 8.10 to Node.js 10.x

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.