question

KatieZ avatar image
KatieZ asked

Why isn't Alexa smart enough to read the correct date on my daily briefing?

It is a problem when I decided to go to daily briefings that I must stay up past midnight to manually (yes manually) uncheck that category so that the new one is the only one that gets picked up. Why isn't the Alexa programmed in such a way to understand the new fresh date and only grab that briefing as it is a brand new day (00:15) and it is set at DAILY?


Also, if I don't do this manually Alexa reads all my meta tags as well before playing 2 episodes.


So I guess when I go on vacation it will just play the one episode every day or with my luck it would say "nothing new here today".


What is the protocol? How does Alexa not understand the dates and times properly? I am manually delisting yesterdays flash briefing and double checking it every night since I went to daily (about 2 weeks ago) and this is really getting old.

How to fix this? I must be doing something wrong.


My skill id:

amzn1.ask.skill.d855546e-2598-4a33-a463-ae6f5d7254ac


It is now 12:56 am. Goodnight. I am so over this.


thanks for your insight


p.s. I had no problems when I was weekly. Is it possible I am not truly daily? I never did get any email that it switched over. There is very little communication. Is it possible your system thinks I am still weekly? let me know. thanks I am using category specific rss feed on my website. Wordpress. all was fine until going daily. I'm repeating myself now because I AMT IRED.



alexaflash briefing
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Amazon_Bernardo Bezerra avatar image
Amazon_Bernardo Bezerra answered

Hi, thanks for posting.

Once the date element is updated in your feed file and your file is saved, Alexa should be able to recognise the new content in up 30 minutes. Is this not happening?

This page provides some information about how to update your feed.

Regards,
Barry

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

KatieZ avatar image
KatieZ answered

Hi @barry@amazon,

This is my pubdate info:

<pubDate>Sat, 30 Mar 2019 06:15:18 +0000</pubDate>


I think I see the error.


I have to select my WordPress site to view dates as year month day and not the USA way.


I am going to fix this in my settings - this might be why the date is not being recognized.


Thanks for making me look over there - that might be it!


Thanks,


Jan


10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

KatieZ avatar image
KatieZ answered

? Still have this problem. I cannot change to the UTC date and time format. So I am still up past midnight manually switching it. Someone just made a new plugin for wordpress I might try it or give up and use a service. My brain cells are tapped out and nothing else is working. So sad, it was working ok until I went daily. So if you don't have correct date and time formats worked out nothing goes right with Alexa - if you are reading this - remember that! done.

1 comment
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hello @KatieZ and thanks for your message.

It looks like a plugin you are using to generate your feed is not working properly. I would suggest getting in touch with their support to understand why is it that your feed is not being generated properly.

As a reminder, your feed must comply to the formatting detailed in this page.

Regards,
Barry

0 Likes 0 ·