question

Gautam avatar image
Gautam asked

Enable skill API responded successfully but still skill simulation API is responding with message skill is not enabled in the development stage

I'm using SMAPIs to enable and simulate my skill, Enable API is responding with success status but when try to access skill using simulation API it is responding with a message that Skill is currently disabled in development stage. Please enable skill in order to call this API.

Same skill is accessible by Alexa developer console and device.

Thanks in advace

smapi
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Jason@Amazon avatar image
Jason@Amazon answered

We are currently investigating issue and I'll reach out again once we have further details.

5 comments
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Ok, thanks for the response.
What I observed is, the problem is not only with my account, simulation API is responding the same when we tried with every account under the same vendor (VoiceITRight) as mine.

0 Likes 0 ·

Hey Jason,

Any progress on this?

0 Likes 0 ·

I would also like to know if any progress was made on this issue

0 Likes 0 ·

When the skill has been enabled for testing, where are you enabling the skill? SMAPI enable-skill, using the Alexa app or enabling testing for development using the test simulator? Make sure you have it enabled on the test simulator and that you are using the ASK CLI with the same vendor ID as the account the skill is being developed on.

0 Likes 0 ·

As per my knowledge, SMAPI are RESTful HTTP interfaces exposed by Amazon to manage skill, let me know if this understanding is incorrect.

I'm using this API: enable skill SMAPI to enable skill. and after getting a successful response from this API, I checked status on test simulator available in Alexa developer console and skill was enabled for testing.

0 Likes 0 ·
vacha_dakwala avatar image
vacha_dakwala answered

I am also facing the same issue. My skill is responding from developer console simulator, but giving error 'Skill is currently disabled in the development stage. Please enable skill in order to call this API.' while invoking the simulator API. Can someone help me out with this?

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Markus Stein avatar image
Markus Stein answered

I'm experiencing the same. I cannot enable the skill and it tells me, it is not enabled.

Trying via "ask smapi set-skill-enablementit only tells "Command executed successfully!" but no more and still disabled

1 comment
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

As this is a slightly older thread, I would suggest posting a new thread with more information specific to your query.

0 Likes 0 ·