question

Mark avatar image
Mark asked ·

Account linking setup

RESOLVED.

The tutorial I mentioned lacks one important step.

If you have no OAuth service brought up and you assuming use the Login with Amazon, then go to

developer console --> Login with Amazon and enable the security profile you already created by walking the tutorial.

Also please note tha redirection URL should look like

https://www.amazon.com/ap/oa/?redirect_uri=https://pitangui.amazon.com/api/skill/link/xxxxxxxxxxxx

Many thanks to RocasV from labworks.io (https://forums.developer.amazon.com/users/256904/Rokas.html).

He helped me a lot resolving my problem and explained the important things.

Without you mate, I could spend much longer time fighting alone !

---------------------------------------------------------------------------

THE ORIGINAL REPORT.

Hey guys !
I'm trying to create a solution with Amazon Alexa and AWS IoT.
Lambda to AWS IoT part is ready, but I can't setup account linking in Amazon Alexa.
This is a real showstopper for now, so any help would be appreciated.

Things I did:
1. Set up and tested Lambda function that kicks AWS IoT.
2. Set up a smart home skill using that tutorial https://developer.amazon.com/blogs/post/Tx3CX1ETRZZ2NPC/Alexa-Account-Linking-5-Steps-to-Seamlessly-Link-Your-Alexa-Skill-with-Login-wit
Got filled all required forms with Client ID and secret, used LWA as OAuth2 provider, set up allowed return URLs in a security profile.
4. In https://alexa.amazon.com/spa/index.html --> Skills --> Your Skills, I see "account linking required" under blue "Enable" button. On click on that button, server returns the following:
Linking unsuccessful.
The authorization server returned with an error parameter. Please refer to https://tools.ietf.org/html/rfc6749#section-4.1.2.1 for more details.

What did I have missed ?

Thanks !

alexa smart homeaccount linkingsmart homeaccount informationskills
7 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

It sounds to me that you missed something in the tutorial, I had similar problem, when I forgot to add redirect url to security profile. Especially step 2, figure 7-8.

0 Likes 0 ·

Rokas, thanks for reply.

Is that tutorial works for you ?

I'll walk again and look twice.

0 Likes 0 ·

Yep, every time I forget how to do it, I use it as a reference. You use amazon account linking right? Here are some more pictures that might help. So this is account linking page in the skill:

This is the security page in the account settings -> Login with amazon -> Web settings:

One of the most important bigs is to add allowed return url from account linking page redirect urls, to security profile as seen here

0 Likes 0 ·
Show more comments

0 Answers