question

newuser-f0ed8c56-aff9-489f-9bab-f6eb6028ccc2 avatar image
newuser-f0ed8c56-aff9-489f-9bab-f6eb6028ccc2 asked ·

Certification feedback that I don't understand

Hi,

I received the following feedback from my skill:

Steps To Reproduce:

User: "Alexa, abre cálculo divisas"
Skill: "Se ha producido un error con la respuesta de la Skill que has pedido"
User: "Alexa, pregunta a cálculo divisas precio dólar"
Skill: "Se ha producido un error con la respuesta de la Skill que has pedido"
User: " Alexa, pregunta a cálculo divisas el precio del dólar"
Skill: "Se ha producido un error con la respuesta de la Skill que has pedido"

But when I try this words in test console it works OK. The only problem is the comma. If I put the comma in the phrse it fails, but without the comma it works, How can I fix this?

Thank you

submission testing certificationtestingcertificationskill builderdev console
2 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Sorry, my skill ID is

amzn1.ask.skill.7110d8f1-6a2e-40f0-9480-d8aac8c2858a

0 Likes 0 ·

Try testing with a physical device or echosim.io to see if you can reproduce the issue.

0 Likes 0 ·

1 Answer

Jamie Grossman avatar image
Jamie Grossman answered ·

I do not believe characters like commas are supported in the testing console. You shouldn't worry about characters like this anyway as when you actually speak to Alexa, characters like this are not passed into the skill.

3 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Then I can't understand the feedback. Because when I test the phrases it works. I even tried with my phisical device and it worked.

0 Likes 0 ·
Jamie Grossman avatar image Jamie Grossman ♦♦ newuser-f0ed8c56-aff9-489f-9bab-f6eb6028ccc2 ·

Investigating.

0 Likes 0 ·
Jamie Grossman avatar image Jamie Grossman ♦♦ newuser-f0ed8c56-aff9-489f-9bab-f6eb6028ccc2 ·

I'm a little confused as to why you are able to test the skill successfully, but the certification team are not able to. Why don't you try setting up a beta test within the skill, adding another account and testing it from there? There must be something different about your testing environment which is allowing the skill to work only for you, so this might help figure out what is happening.

0 Likes 0 ·