question

Amazon Customer avatar image
Amazon Customer asked

Ask init skips Opening Browser to Verify Amazon Credentials

Hi There,

I am trying to use the ask init command so that I can link my Amazon Developer account with the ASK CLI interface. However, when i press enter after ask init following happens:

  1. It asks me for new Profile Name which i Type
  2. Press Enter
  3. It skips everything & i am back to command prompt

See screenshot below:

How do i make ask init work?

I setup AWS i think by using the command ask init --aws-setup<br>

The above command for aws setup worked perfect but dont know why ask init skips everything & takes me back to command prompt

Would really appreciate your help

alexa skills kitask cli
ask-init-error.png (11.8 KiB)
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Amazon_Bernardo Bezerra avatar image
Amazon_Bernardo Bezerra answered

Hello and thanks for posting.

Have you tried using the --no-browser option?

ask init --no-browser

Regards,
Barry

6 comments
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Amazon Customer avatar image Amazon Customer commented ·

Hi Barry, Yes that too produces the same result. Doesnt stop after i enter the profile name, it takes me straight back to command prompt.

capture.png

Is it that i have to reinstall node.js ; is the ask-cli sdk corrupt maybe ?

0 Likes 0 ·
capture.png (20.8 KiB)
Amazon_Bernardo Bezerra avatar image Amazon_Bernardo Bezerra ♦♦ Amazon Customer commented ·

Hi and thanks for the feedback.

Sometimes antivirus and firewalls can interfere with this part of the authentication. Can you please disable them and try again?

Regards,
Barry

0 Likes 0 ·
Amazon Customer avatar image Amazon Customer Amazon_Bernardo Bezerra ♦♦ commented ·

Hi Barry, Tried disabling my McAfee Firewall . Same behavior as before - it skips to command prompt once i give it a New Profile name

0 Likes 0 ·
Show more comments
caffeinePlease avatar image
caffeinePlease answered

I'm setting up a new device and running into this issue as well. Tried without firewall and exact same problem.

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.