question

MansaaDevOps avatar image
MansaaDevOps asked

Issues while setting Alexa Smart Home skill

I am trying to create a smart home skill using Smart Home API but having issues with testing the skill. So I have set up everything including lambda function, Client Id, secrets keys etc but it keeps giving the messages "You will need to configure the account linking skill capability in order for the Smart Home Voice Model to be functional"" and when I go to the test page it says "To test a SmartHome or Video skill, first enable the skill with the Alexa companion app, complete any required information, and then refresh this page." I have tried everything but not able to find what I am doing wrong. Any help would be appreciated.

alexa smart homeaccount linking
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Jenn@amazon avatar image
Jenn@amazon answered

Where do you see the message "You will need to configure the account linking skill capability in order for the Smart Home Voice Model to be functional"?

Did you link your account through the Alexa App?

Log into alexa.amazon.com using the same account used to create the Skill. Under the 'Your Skills' section, find the skill you would like to Test and link your account there.

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

MansaaDevOps avatar image
MansaaDevOps answered

Thanks for the answer Jenn. I was able to make progress on above but again stuck while enabling the skill.

I am trying to connect the Alexa account using the user from my existing pool id but every time I log in using the credentials it says "Incorrect username & password". I am 200% sure that username and password are correct and even tried deleting and resetting the password but not sure how to resolve it.

Steps Followed:

1) Set up the Cognito pool and created a user

2)Created a Pre-generated Lambda function with Alexa Smart Home skill

3)Created a smart home skill and enter the account linking credentials using the tutorial https://stackoverflow.com/questions/48667128/what-is-the-correct-access-token-uri-for-aws-cognito-and-alexa-account-linking

4)Enable the Smart home skill and it takes to the login screen

5)Entered the credentials and getting the error (attached screenshot)

I am not sure what exactly is the issue and there is not debugging console where we can check the logs. Any help would be appreciated.

1 comment
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Can you share the Skill ID for your smart home test skill? I'll see if I can see what happened in our logs.

0 Likes 0 ·