question

newuser-73baa319-e6b0-4c9d-8243-d3cdec238634 avatar image

Device discovery failing through Alexa app (lambda is not triggered) but works with simulator on developer portal?

I am not able to trigger smart home lambda adapter through Alexa app due to which device discovery fails. However it's working through Alexa Simulator on developer portal. All the initial processes are working fine (account linking) except device discovery through the app.

I am using English (IN) language and EU (Ireland) as lambda endpoint.

alexa smart homelambdadevice discovery
10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

dmellent avatar image
dmellent answered

Make sure your Echo device is turned on.

I've experienced this before, and I believe my issue at that time was because the Echo device was turned off. I'm experiencing this again right now (with someone who does not have an Echo device, just trying to test the Skill through the Alexa App), and I am trying to find documentation to confirm this requirement (that they have an Echo device, and it must be turned on).

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Anand@Amazon avatar image
Anand@Amazon answered

As this issue is specific to your account, please file a contact us here where we will be able to assist further. Please provide login credentials as well for further debugging.

10 |5000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.