question

lodestoneanimation avatar image
lodestoneanimation asked ·

Unable to Launch Kindle Fire 2nd Gen & Kindle Fire HD Emulators

Hello, I have been attempting to launch both the Kindle Fire 2nd Gen and the Kindle Fire HD emulators, but have not had success with either. I have installed both packages in the SDK Manager, and have set up both emulators in the AVD Manager. Both show as "A valid Android Virtual Device" in my AVD window, and neither device throws an error when I start it. However, although both devices look like they are starting properly, neither one loads. I am still able to run the original "Kindle Fire" emulator using the same procedure listed above. I am wondering if anyone else has run into this problem, and if so, if they know a workaround to get the emulators started? (I am running Windows XP, if that's helpful.) Any advice would be appreciated! Thanks in advance, John
fire tablet
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Samuel@Amazon avatar image
Samuel@Amazon answered ·
Hi John, We are looking in to your problem and we will get back to you on this. Mean while when you said 'able to start it properly and neither one loads' means, you are not able to load your test app on these 2nd Gen and HD7 emulators via eclipse? You can also install apps on emulator directly from command line using adb command. Please find the commands given below. Navigate to " \platform-tools" directory and run this command.. adb -e install Thanks
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

lodestoneanimation avatar image
lodestoneanimation answered ·
Hi, Samuel - I'm trying to run the new Kindle Fire emulators directly from the AVD Manager (and not Eclipse). The original Kindle Fire emulator works just fine (listed as "Kindle Fire (Amazon)", but I am unable to launch the "Kindle Fire (2nd Generation) (Amazon)" and the "Kindle Fire HD 7' (Amazon)" options. Both of the new options appear to start their respective launches properly, but the actual emulator never appears on screen as it does when I choose the original KF option. Thanks again, John
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Samuel@Amazon avatar image
Samuel@Amazon answered ·
Hello John,Once you started AVD Manager using android script. Please click start on the Kindle Fire( 2nd Generation) or Kindle Fire HD7 AVD, Please select your custom scale to display real size to see the proper emulator size. I guess, default "Screen Size(in)" is given 3, Please change it to appropriate size(scale must be between 0.1 - 3.0). Once you are done with the change, please click on Launch and you can see the emulator. Hope this helps, Thank you.
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

lodestoneanimation avatar image
lodestoneanimation answered ·
Hi, Samuel - I tried changing the screen sizes to 7.0 for the KF HD 7", and to 8.9 for the KF 2nd Gen before launching, but still no luck. I can see the process in the task manager for a while after I hit "Launch", but the process dies after a few minutes without the emulator bring launched. (Everything is still working normally and correctly with the original KF emulator.) Thanks again, John
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Samuel@Amazon avatar image
Samuel@Amazon answered ·
Hi John, When you say that you have given screen size 8.9 and 7.0 for 2nd Generation and HD, you are entering "7.0" and "8.9" in "Screen Size (in)" field box?, I guess you might need to increase the value so that the emulator will be visible. When you launched, do you got any error message displayed for HD and 2nd Generation emulators?
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

lodestoneanimation avatar image
lodestoneanimation answered ·
Hi, Samuel - Yes, 7.0 and 8.9 were the values I had entered for screen size. I just tried launching again with larger numbers, "14.0" and "18.0" but still no luck. And no, that's the strange part - I am not getting any errors. Everything appears to start correctly, but the process is killed somehow before the emulator appears. (I could send you a screenshot if that would be helpful, but I'm not sure how to post one on this forum.) Thanks again, John P.S. Could the dpi setting have something to do with the launch failure? The default appears to be 96, but maybe this is incorrect?
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Samuel@Amazon avatar image
Samuel@Amazon answered ·
Hi John, Yeah, you can change dpi and check. The dpi size '96' will cause emulator window out of view. Please check with lower value of dpi( say 30 or 35). If the problem still persists, you can delete the created AVD and you can re-create again.
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

lodestoneanimation avatar image
lodestoneanimation answered ·
Hi, Samuel - Still not getting the emulator to launch with these suggestions. I'm wondering if maybe my NextGen KF SDK's are somehow corrupt? If so, is there an easy way to uninstall/re-install just these components? Thanks again, John
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Samuel@Amazon avatar image
Samuel@Amazon answered ·
Hi John, Normally with these settings on AVD, emulator should load and start up. However, yeah, you can delete specific components from Android SDK Manager and re-install only those components again.
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

David avatar image
David answered ·
I'm getting the same thing too. It just doesn't start. I'm on a MAC.
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.