question

darianbjohnson avatar image
darianbjohnson asked

ASK CLI does not deploy a new skill and does not list skills with clone command

I just downloaded the new version of the ASK CLI (1.1.0). I also upgraded to the latest version of the AWS CLI (1.14). The ASK CLI does not seem to work. The "clone" command does not provide a list of my skills and the "deploy" command (after using "new" to create a test skill) hangs. My aws.cli looks like this:

{
  "profiles": {
    "default": {
      "aws_profile": "default",
      "token": {
        "access_token": "Atza|....",
        "refresh_token": "Atzr|....",
        "token_type": "bearer",
        "expires_in": 3600,
        "expires_at": "2018-02-18T06:12:49.613Z"
      },
      "vendor_id": "XXX...."
    },
    "Developer": {
      "aws_profile": "default"
    }
  }
}

What's interesting is that my token is set to expire Feb 18 2018... which doesn't make sense.

Any suggestions?

ask cli
2 comments
10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I'm going more investigation... it looks like the token information is not being added/updated when I authenticate via the browser (even though I get a message saying that I have authenticated successfully). Any suggestions on how to resolve?

0 Likes 0 ·

1 Answer

darianbjohnson avatar image
darianbjohnson answered

Ok, looks like the way to fix this is to get an older version of simple_oauth. See here for instructions https://forums.developer.amazon.com/idea/117695/ask-cli-broken-by-simple-oauth2-dependency-update.html?childToView=119006#comment-119006

10 |5000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.