article

Amelia@Amazon avatar image
Amelia@Amazon Posted · · edited ·

How to Support Fire OS 5.0 for all Amazon Fire TV and Fire TV Stick Devices

Summary:

To ensure that your LIVE app is compatible with the new Amazon Fire TV (Fire OS 5), the Fire TV (Previous Generation) (Fire OS 3) and the Fire TV Stick (Fire OS 3), we recommend updating your app to support all devices using a single binary.

If your existing binary only supports Fire OS 3, please use the Fire OS 5.0 Developer Preview (https://developer.amazon.com/public/solutions/platforms/android-fireos) to evaluate and troubleshoot any compatibility issues with your app such that your app binary supports

  1. FireTV (Fire OS 5)
  2. Fire TV (Previous Generation) and Fire TV Stick (Fire OS 5)
  3. Fire TV (Previous Generation) and Fire TV Stick (Fire OS 3)

Once you submit your updated binary to the Amazon Developer Portal, you will receive an email with app test results. If your app has been determined to be incompatible, you have the following options to resolve these issues:

  1. Address any functional issues and resubmit the single binary.
  2. Maintain your LIVE app submission and add a new binary targeting the new Amazon Fire TV (Fire OS 5) to your published app (https://developer.amazon.com/appsandservices/support/submitting-your-app/tech-docs/updating-binary-apks-for-a-published-app#Adding%20New%20Binaries%20to%20a%20Published%20App)

If you have additional questions on the submission process or your test results please Contact Us at https://developer.amazon.com/public/support/contact/contact-us

Keywords: Fire OS 5, submission, compatibility

KB_229

androidlollipop
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Article

Contributors

brizzlebrazzle contributed to this article